DBShop论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 27559|回复: 21

DBShop电子商务网店系统 V0.9 Release 正式版发布

 关闭 [复制链接]
发表于 2014-2-16 16:18:54 | 显示全部楼层 |阅读模式
已集成在线更新功能模块,集成时间:2014年3月9日下午7点半

+-----------------------------------------------+
DBShop 电子商务网店系统
+-----------------------------------------------+
DBShop电子商务网店系统,是一套使用PHP语言构建,基于ZendFramework 2 框架开发的在线购物网店系统。

+-----------------------------------------------+
DBShop 电子商务网店系统环境要求
+-----------------------------------------------+
1、操作系统方面,DBShop网店系统具有跨平台特性,可运行在 Linux/Unix/MAC OS/Windows 等操作系统下。DBShop
网店系统推荐使用 Linux/Unix 操作系统,不仅免费,而且能够提供更好的稳定性和负载能力。

2、除操作系统外,需要 web 服务器(如 Apache、Nginx 、IIS 等,不推荐IIS),PHP 5.3.3及以上版本,MySql 5.0及
以上版本,Zend Guard Loader(PHP 5.3.3 对应版本 Zend Guard Loader 5.5 | PHP 5.4 对应版本 Zend Guard Loader 6.0

3、如果您是虚拟空间用户,需要咨询空间商您目前使用的空间是否已经安装有上述支持软件。MySql账户需要拥有 CREATE、
DROP、ALTER 等执行权限,虚拟空间不低于50M,数据库空间不低于10M,如果您不十分了解请咨询空间商。

+-----------------------------------------------+
DBShop 电子商务网店系统安装
+-----------------------------------------------+
将程序目录下的所有文件,上传到虚拟空间您需要安装的位置,需要特别注意在使用ftp软件上传程序时,一定要使用二进制方式上传。
上传完成后,打开如下网址
http://您的域名/程序目录/

当您第一次使用时,系统会自动跳转到安装目录,您只需要按照提示一步一步顺利完成安装,即可使用。
如果您需要重新安装,删除data目录下的install.lock文件,然后按照上面的安装顺序,安装即可。

DBShop V0.9 Release 2014.02.16 更新记录
-------------------------------------------------
修正 前台分类推荐商品中的title标记对应的名称编写错误问题
修正 新注册会员发送欢迎信息内容中的email标记没有被替换问题
修正 后台客户设置中的欢迎和注册协议内容,将内容中的双引号替换为单引号,双引号情况下无法正常保存
修正 后台客户设置中,当没有上传新头像,点击保存设置操作,原默认头像路径出错问题
修正 没有设置市场价格时,有规格属性的商品,前台规格切换出错
修正 在php5.4环境下,前台首页的路由地址出现错误无法访问的问题
修正 前台会员登录后,后台删除该会员,会员在购物车和会员中心时,会自动退出登录
修正 系统安装后,后台首页显示的更新时间为安装时间,应为系统功能的实际更新时间
修正 后台订单打印页面,点击打印按钮无法进入打印操作

改进 后台商品编辑销售规格的价格和库存可以为0
改进 验证码输出的json数据中取消验证码字符串输出,防止机器人注册
改进 后台没有添加品牌内容时,前台首页不显示品牌内容框
改进 删除会员的同时如果会员有头像,删除头像
改进 后台首页系统更新信息变为横幅提示条,原来是在版本信息旁提示有更新的标签显示
改进 将原始语言文件加入了系统中,方便想修改语言的朋友修改
改进 移除DBShop对于配置环境中默认ZF2框架的依赖,只依赖于DBShop系统内的ZF2框架

新增 整合第三方电子商务统计分析,简易整合【查看开启方法


系统测试地址
前台:http://test.dbshop.net/
后台:http://test.dbshop.net/admin/   管理员 dbshoptest   密码 dbshoptest


系统演示地址
http://demo.dbshop.net/


重要提示:DBShop电子商务网店系统为全加密系统,并不适合二次开发或研究代码者使用。为了避免浪费您不必要的时间,特在此说明。如果您只是为了使用系统搭建一个属于自己的网店系统,并不打算二次开发或研究代码,您可以放心下载使用本系统。


IE支持 IE7+

安装教程:http://help.dbshop.net/index.php?title=%E7%B3%BB%E7%BB%9F%E5%AE%89%E8%A3%85

系统下载地址
本地直接下载(适合PHP 5.3.3+环境):http://www.dbshop.net/download/DBSHOP_0.9_Release.zip

本地直接下载(适合PHP 5.4环境):http://www.dbshop.net/download/PHP5.4_DBSHOP_0.9_Release.zip

请选择对应您PHP版本的程序包进行下。


回复

使用道具 举报

 楼主| 发表于 2014-2-16 17:33:43 | 显示全部楼层
DBShop电子商务网店系统 V0.9 Release 正式版升级包

升级包未集成在线更新功能模块,请升级到 V0.9 Release 正式版后,自行添加在线更新功能模块

升级适用版本:[V0.9 RC 20140125]

升级更新方法说明
1、打开您网站data目录下面的Version.php文件主要看出如下内容

define('DBSHOP_INSTALL_TIME', '2014-02-16');

将其中的 '2014-02-16' 复制,然后替换掉更新包中对应文件的对应内容,不同时间安装显示的日期不同
所以您站点的安装时间不一定是 '2014-02-16' 以您站点的安装时间为准。
另外更新包中data下的Version.php还需要替换的内容是

define('DBSHOP_UPDATE_TIME', '2014-02-16');

其中的 '2014-02-16' 为您更新补丁更新包的日期,以您当前的日期为准,进行修改即可。

以上两个修改信息,不修改也可以,但是为了正确显示您的安装日期和更新日期,建议手动进行修改。

注意:在修改php文件时,尽量不要使用windows自带记事本工具进行修改,可能会导致未知错误。可使用
Sublime Text、EditPlus或者Dreamweaver,进行修改。

2、更新包的内容替换完成后,将更新包整个目录覆盖到网站相同目录。至此,版本更新完毕


升级更新包下载地址(PHP5.3):http://www.dbshop.net/download/DBSHOP_0.9_Release_update.zip
升级更新包下载地址(PHP5.4):http://www.dbshop.net/download/PHP5.4_DBSHOP_0.9_Release_update.zip


回复 支持 反对

使用道具 举报

发表于 2014-2-17 00:28:39 | 显示全部楼层
不能把安装日期放到别的文件里么?

那样不就可以不 用总改他.........都啥年代了.升级程序还要手工改这个的说....
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-2-17 09:14:25 | 显示全部楼层
你就自己动手更新吧,呵呵呵,这里没有大动,原因是这里为自动更新功能做的准备。下个版本考虑加入自动更新功能。
很多功能前期可以没有,但是要考虑到,目前你看到的觉得有用没用的,其实都是为以后新的功能做的准备。
回复 支持 反对

使用道具 举报

发表于 2014-3-2 23:20:02 | 显示全部楼层
没有install 目录啊
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-3-2 23:34:18 | 显示全部楼层
webyanhai 发表于 2014-3-2 23:20
没有install 目录啊

没有install目录就没法安装莫?你有试着安装莫?不要去找什么install目录,只要你的环境符合安装要求,自然就安装了。
回复 支持 反对

使用道具 举报

发表于 2014-3-3 07:58:41 | 显示全部楼层
我用的iis +php+mysql  运行就跳到 install 目录了
回复 支持 反对

使用道具 举报

发表于 2014-3-25 09:48:19 | 显示全部楼层
打开时提示错误
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, admin@example.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
是什么情况?
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-3-25 09:55:23 | 显示全部楼层
心锁 发表于 2014-3-25 09:48
打开时提示错误
Internal Server Error

检查下你的服务器,另外去上面有如何安装dbshop,里面有服务器方面的内容。此并非程序的问题。
回复 支持 反对

使用道具 举报

发表于 2014-3-25 09:59:58 | 显示全部楼层
admin 发表于 2014-3-25 09:55
检查下你的服务器,另外去上面有如何安装dbshop,里面有服务器方面的内容。此并非程序的问题。 ...

应该是环境的问题,我看了环境的安装,安装的也是您这边提供的zend那个程序,服务也启动了,也改了conf里的文件了,但是就是提示这个错误,还有什么设置需要改吗?
回复 支持 反对

使用道具 举报

发表于 2014-3-25 10:04:07 | 显示全部楼层
我发现是所有的php文件都无法执行,直接安装这个zend启动的服务是不是没有php环境?
回复 支持 反对

使用道具 举报

发表于 2014-3-25 10:04:24 | 显示全部楼层
安装完成 进后台就出这个怎么回事 急求解决
请不要替换官方提供的前台模板 shopfront/common/index.phtml 文件
回复 支持 反对

使用道具 举报

发表于 2014-3-25 10:05:35 | 显示全部楼层
求帮助  后台进不去   进后台就出现“请不要替换官方提供的前台模板 shopfront/common/index.phtml 文件

本人QQ11225567   官方有没有QQ群啊
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-3-25 10:06:46 | 显示全部楼层
心锁 发表于 2014-3-25 09:59
应该是环境的问题,我看了环境的安装,安装的也是您这边提供的zend那个程序,服务也启动了,也改了conf里 ...

这就需要你自己去测试了,需要一步一步去测试了,你首先要确定你配置的环境是否正常,是否能执行php文件。能提示的也就是这些了,环境不同配置不同。网上的教程也是蛮多的。不建议去使用iis,本身iis配置重写麻烦。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-3-25 10:09:02 | 显示全部楼层
jinxuesheng 发表于 2014-3-25 10:05
求帮助  后台进不去   进后台就出现“请不要替换官方提供的前台模板 shopfront/common/index.phtml 文件

...

看来你没有安装在线更新功能,这个补丁在在线更新服务器上已经发布有一段时间了。

如果是后台设置了关闭状态,请看下面这个帖子
http://bbs.dbshop.net/forum.php? ... typeid%26typeid%3D2

如果是本地环境出现这个:请检查第一端口是web服务器默认端口80,如果不是,可能会出问题。第二,在本地设置了host 用了个域名,这也会出问题。
还有一种情况:修改或者替换了前台模板文件 default\shopfront\common\index.phtml也会出现上面的问题。

官方没有QQ群
回复 支持 反对

使用道具 举报

发表于 2014-3-25 10:10:45 | 显示全部楼层
我问最后一个问题,是不是Zend Server不直接支持PHP,还需要另行安装?
回复 支持 反对

使用道具 举报

发表于 2014-3-25 10:12:58 来自手机 | 显示全部楼层
安装环境不对,,,,仔细看下,,需要啥,。也是都是否正常再装
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-3-25 10:13:41 | 显示全部楼层
心锁 发表于 2014-3-25 10:10
我问最后一个问题,是不是Zend Server不直接支持PHP,还需要另行安装?

Zend Server本身带有php,它是php公司发布的集成环境。
回复 支持 反对

使用道具 举报

发表于 2014-3-25 10:16:09 | 显示全部楼层
admin 发表于 2014-3-25 10:13
Zend Server本身带有php,它是php公司发布的集成环境。

那就奇怪了,我的环境也启动了,我用了一个最简单的echo都打印不出来,提示一样的错误!
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|北京珑大钜商科技有限公司 ( 京ICP备15047709号-3 )

GMT+8, 2021-10-26 07:49 , Processed in 0.166625 second(s), 22 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表